Computer Community

Unterhaltung (neue Beiträge)Dos-Emulator

StartseiteAntworten

1 - 30 von 97

Gehe zur Seite

Seite 1 von 4

0

Start der Unterhaltung

Falls jemand Lust auf alte Spieleklassiker hat, diese aber unter Windows XP nicht zum Laufen bringt, dem sei DosEmu ans Herz gelegt.

Dieser bildet unter Windows einen DOS-PC nach. Danach kann man sogar Windows 3.1 starten und ein bißschen in Nostalgie schwelgen :mrgreen:

Hier findet man nützliche Informationen zum Einsatz und den Voraussetzungen für DosEmu.

Antworten
nobody4ever

Reputation

13.380

  • Thread ErstellerThread Ersteller
  • 8.245 Beiträge
  • registriert vor 13 Jahren

96 Antworten

0

Anonymer Gast

Hi, ich habe mir die datei runtergeladen. Habe aber Probleme es zu entpacken, kannst mir vieleicht weiterhelfen? Die Seite, die du noch angegeben hast, hilft mir nicht weiter.


0

nobody4ever

Ach du Schande da hab ich was durcheinandergebracht :oops:

DosEmu ist für Linux, für Windows XP brauchst du DosBox :arrow: http://dosbox.sourceforge.net

nobody4ever

Reputation

13.380

  • Thread ErstellerThread Ersteller
  • 8.245 Beiträge
  • registriert vor 13 Jahren

0

Anonymer Gast

Danke!


0

Anonymer Gast

:cry: Ich habe mir DosBox runter geladen und installiert. Hab es hin bekommen Crusader und Xcom 3 zu installieren aber spielen kann ich sie nicht. Bei xcom wird nur das anfangs Video abgespielt, was ich nur hören und nicht sehen kann, danch gehts nicht weiter. Crusader läßt sich irgendwie gar nicht starten. Gibs es da noch irgendwelche Einstellungen die ich änder muß, damit ich die Speile spielen kann?


0

nobody4ever

Normalerweise kann man sofort spielen - kommt aber auch wieder auf die Anforderungen des Spiels an. Leider hab ich beide Spiele nicht, dewegen kann ich dir nur ein paar theoretische Hinweise liefern:

Im Startmenü findes du unter DosBox einen Link zur Datei dosBox.conf.

ich würde mich mal mit folgenden Werten experimentieren: Vorher lege dir aber eine Sicherheitskopie der Datei an - sich ist sicher !

Bei mir standardmäßig waren aktiv:

fullscreen=false
=> mal auf true stellen
fulldouble=false
=> mal auf true stellen
fullfixed=false
fullresolution=1024x768
=> mal auf 800x600 oder 640x480 stellen

memsize=16
=> mit 32 oder 64 probieren

nobody4ever

Reputation

13.380

  • Thread ErstellerThread Ersteller
  • 8.245 Beiträge
  • registriert vor 13 Jahren

0

kollegga

Hallo nobody4ever

Ich beschäftige mich auch mit dem Thema dos emulator.

Ich kriege den Doppelpunkt in dosbox nicht hin.
statt : tippt er bei mir > ein.
Die Sprache und das Sprachgebiet sind bei mir auf Deutsch eingestellt.

wie krieg ich den Doppelpunkt hin. :oops:
Den brauche für die Sache mit dem "mount"
Danke

kollegga

Reputation

0

  • 3 Beiträge
  • registriert vor 12 Jahren

+2

nobody4ever

Hi, da ist jetzt ein bißchen Arbeit nötig.

Zuerst einmal mußt du dir das deutsche Sprachenset runterladen:
http://dosbox.sf.net/tools/DOSBox-german-lang-063.zip

Entpacke das in den Ordner wo du DosBox installiert hast.

Öffne dann die dosbox.conf.

Suche dir die Stelle mit language= und änder sie in
language=deutsch.lng

Danach gehst du zum [autoexec] Bereich ganz unten und fügst folgendes ein:

[autoexec]
# Lines in this section will be run at startup.
mount c C:\Programme\DOSBox-0.63
c:\keyb gr

Du kannst nat. auch einen anderen Laufwerksbuchstaben verwenden. Schon hast du ein deutsches Dos :wink:

Ich an deiner Stelle würde auch hier gleich die ganzen mount Sachen reingeben. Dann ersparst du dir die mühsame Eingabe jedesmal :idea:

nobody4ever

Reputation

13.380

  • Thread ErstellerThread Ersteller
  • 8.245 Beiträge
  • registriert vor 13 Jahren

0

kollegga

Hi nobody4ever

Danke für die Hilfe. Hätte es mir nicht so (relativ) kompliziert vorgestellt.

Das mit der deutschen Sprache hat gut geklappt.
Die Intro und die Hilfe sind auf Deutsch.
Doch statt des Doppelpunktes : krieg ich immer noch ein >. :roll:

Danke

kollegga

Reputation

0

  • 3 Beiträge
  • registriert vor 12 Jahren

0

nobody4ever

Hast du auch den Part mit [autoexec] gemacht ? Ohne den keyb gr Part bleibt weiterhin die englische Tastatur aktiv.

nobody4ever

Reputation

13.380

  • Thread ErstellerThread Ersteller
  • 8.245 Beiträge
  • registriert vor 13 Jahren

0

kollegga

Ja das habe ich auch eingefügt; in der letzten Zeile war das.

Der Installationspfad ist auch wie in deiner Beschreibung.
C:\Programme\DOSBox-0.63

kollegga

Reputation

0

  • 3 Beiträge
  • registriert vor 12 Jahren

0

Unrial

Hi alle!

An was ich mich aus der DOS-Zeit noch erinnern kann war der Doppelpunkt ":" mit Shift Ö also "Ö" hinzubekommen.

Bin mir aber nicht mehr ganz sicher.

Mit der Alt-Taste kann man auch alle Zeichen generieren im Dos! Z.b.: Alt + 255 (Num-Feld) ist das Leerzeichen :P

Unrial

Reputation

0

  • 5 Beiträge
  • registriert vor 12 Jahren

0

dw182

Hallo,

ich habe gerade den DOS-Emulator im Test.
Kann mir jemand sagen ob und wie ich einen Drucker aus der DOS-Box ansteuern kann.
Ich habe ein altes DOS-Programm und muss auch daraus drucken können.

Gruß

Dirk

dw182

Reputation

0

  • 4 Beiträge
  • registriert vor 12 Jahren

0

JustMe

Hallo und Willkommen!

Diese Frage dollte eigentlich einen eigenen Thread haben. Schau Dir mal das hier an. http://www.jasik.de/tipps%20&%20tricks/tipp09.htm

Vielleicht hilft es Dir weiter.

Nice Greetz

JustMe

Reputation

12.780

  • 8.219 Beiträge
  • registriert vor 12 Jahren

0

dw182

Vielen Dank für die schnelle Antwort.

Klappt das auch mit lokal an den Rechner (LPT1) angeschlossenen Druckern?

Ich bin einfach schon zu lange aus dem Thema DOS raus.

viel Grüße

DW

dw182

Reputation

0

  • 4 Beiträge
  • registriert vor 12 Jahren

0

JustMe

Schau mal auf diese Seite:
Die sollte alle Deine Fragen über DOS beantworten :wink:
http://www.antonis.de/dos/dos-tuts/piep/
http://www.ta7.de/txt/dos/dos0006.htm

Nice Greetz

JustMe

Reputation

12.780

  • 8.219 Beiträge
  • registriert vor 12 Jahren

0

dw182

Hallo Leute,

ich kämpfe jetzt seit ein paar Tagen mit der DOS-Box.

Gibt es eine Möglichkeit der DOS-Box den net-Befehl "bei zubringen" ?

Ich muss den LPT1 einbinden aber die DOS-Box kennt den Befehl net leider nicht.

Gruß

DW182

dw182

Reputation

0

  • 4 Beiträge
  • registriert vor 12 Jahren

0

Hasbulat

nobody4ever hat folgendes geschrieben:

Ach du Schande da hab ich was durcheinandergebracht :oops:

DosEmu ist für Linux, für Windows XP brauchst du DosBox :arrow: http://dosbox.sourceforge.net

Ich habe dosbox bei mir installiert (habe Win2000). Es klappt gut mit "mounten".
Allerdings, wenn ich es versuche DOS-Spiel "Conquest of the New World" zu spielen - dauert es alles ewig lang, bis alles aktuallisiert und ausgerechnet wird. Das Spiel ist praktisch unspielbar.

Hat jemand eine Idee, woran es liegen konnte?

Danke im Voraus

Hasbulat

Reputation

0

  • 1 Beiträge
  • registriert vor 11 Jahren

0

nobody4ever

Hi und herzlich willkommen !

Naja, die Emulation wird bei aufwändigeren Spielen schon sehr gefordert.
Was du machen kannst wäre die CPU Time für das Spiel hinaufzudrehen.

nobody4ever

Reputation

13.380

  • Thread ErstellerThread Ersteller
  • 8.245 Beiträge
  • registriert vor 13 Jahren

0

dw182

Hallo,

ich muss leider nochmal mit meinem alt bekannten Thema nerven:

Ich schaffe es leider immernoch nicht aus der DOS-Box auf einen an LPT1 angeschlossenen Drucker zu zugreifen :( .

Ich habe ein ziemlich altes Programm das nur unter DOS läuft und einen Drucker am LPT1 sucht. Kennt jemand eine Möglichkeit mit der ich es hinbekomme den LPT1 in die DOS-Box zu basteln?

nice Greets
DW182

dw182

Reputation

0

  • 4 Beiträge
  • registriert vor 12 Jahren

0

JustMe

Was für einen Drucker hast du denn?
Vielleicht kann dir das hier weiterhelfen
http://www.wer-weiss-was.de/theme30/article1024315.html

JustMe

Reputation

12.780

  • 8.219 Beiträge
  • registriert vor 12 Jahren

0

nobody4ever

dw182 hat folgendes geschrieben:

Hallo,

ich muss leider nochmal mit meinem alt bekannten Thema nerven:

Ich schaffe es leider immernoch nicht aus der DOS-Box auf einen an LPT1 angeschlossenen Drucker zu zugreifen :( .

Ich habe ein ziemlich altes Programm das nur unter DOS läuft und einen Drucker am LPT1 sucht. Kennt jemand eine Möglichkeit mit der ich es hinbekomme den LPT1 in die DOS-Box zu basteln?

nice Greets
DW182

Hi, ich schaus mir am Abend an, weil in der Arbeit hab ich keine DosBox im Einsatz :wink:

nobody4ever

Reputation

13.380

  • Thread ErstellerThread Ersteller
  • 8.245 Beiträge
  • registriert vor 13 Jahren

0

druschba

Hallo, ich habe mich in den letzten Tagen intensiver mit der DOS-Emulation unter XP beschäftigt. Die Spracheinstellungen klappen. Mein Problem: Ich habe noch ein Original
von "D/GENERATION" und wollte es wieder mal spielen. Leider kommt jedes mal diese Info.
"Please insert your original Dgen Install Disk 1 in Drive A:.". Wenn ich dann DOS (win98) boote kann ich installieren und spielen (ohne Ton). Wenn ich dann unter der DOSBox spiele, wird das Programm nach kurzem beendet, weil er meint die Hardware hätte sich verändert. Ich sollte also nochmal installieren. Und dann habe ich natürlich wieder die blöde Meldung. Wer kann helfen ?

druschba

Reputation

0

  • 3 Beiträge
  • registriert vor 11 Jahren

0

JustMe

Hallo Druschba. Im DOS wurde deine Grafikkarte anscheinend nicht erkannt. Theoretisch müsstest du den DOS Treiber installieren. Was die DOS-Box angeht weiss nicht genau. Könnte sein das es auch mit der Soundkarte zusammenhängt. Die sich ja in dem Sinne geändert hat das es die nun gibt.

JustMe

Reputation

12.780

  • 8.219 Beiträge
  • registriert vor 12 Jahren

0

druschba

Hallo JustMe, mit Dos-Boot-CD kann
Spiel gespielt werden. Da habe ich allerdings nur den Super-Speaker-Sound. Aber immerhin (Da geht mein Vadder immer hin). Die Dosbox
habe ich schon kreuz und quer parametriert. Alte config-Befehle mit
reingehauen. Sound und Mouse ausgeschaltet. Manchmal komme ich einen Raum weiter und dann ist Schluss. Habe auch schon die Spielfähigkeit auf einer Seite geprüft.
Dieser fehler ist bekannt und soll behoben sein mit dem Programm "Dgenvga.exe". Das Original heißt "Dgen.exe". Beim Installieren der Original-Disketten unter MSDOS zeigt er u.a. auch solch eine Datei "Dgenvga.exe" an.
Allein, sie ist nicht zu finden. Und das Remake "Re/Generation" ist nicht so mein Ding. Ich habe jetzt schon mehrere Tage mit der DOSBox experimentiert. Nicht mehr lange und ich werde die Disketten zersägen (Haben schon 15 Jahre überdauert ! - Das muss reichen !).

druschba

Reputation

0

  • 3 Beiträge
  • registriert vor 11 Jahren

0

nobody4ever

Die Settings für die DOSBox einzustellen ist über das Config File mühsam.

Ich verwende dafür seit neuestem D-Fend => http://members.home.nl/mabus/

Damit kann man perfekt die Einstellungen optimieren, wie z.B: CPU Priorität etc.

Einfach damit rumspielen und schon holt man mehr Speed aus dem Emulator raus :D

nobody4ever

Reputation

13.380

  • Thread ErstellerThread Ersteller
  • 8.245 Beiträge
  • registriert vor 13 Jahren

0

habasch

hallo
bin kein computerfreak möchte abe rwieder mal ein uraltes dos spiel auf einer spielesammlung cd spielen...
ich habe in der dosbox gemounted dann den richtigen pfad(.exe eingegeben)
am anfang ging es,jedoch war steuung beschissen usw...dann die änderungen die hier im forum waren gemacht in der conf

fullscreen=true
fulldouble=true
fullfixed=false
fullresolution=800x600
output=surface
hwscale=1.00
autolock=true
sensitivity=100
waitonerror=true
priority=higher,normal
mapperfile=mapper.txt

bla bla bla
memsize=32

führte dazu dass nach mounten und starten der exe datei was kam von wegen arbeitsspeicher zu klein,mindestens 512kb notwendig
wie bringe ichdieses spiel zum laufen?verzweifelter gamer grüsstund dankt im voraus

habasch

Reputation

0

  • 2 Beiträge
  • registriert vor 11 Jahren

0

habasch

weiss es denn keiner?kann doch nicht sein....

habasch

Reputation

0

  • 2 Beiträge
  • registriert vor 11 Jahren

0

nobody4ever

Hallo und herzlich willkommen !

2 Fragen:

a) um welches Spiel handelt es sich ?

b) was zeigt dir die DosBox an wenn du mem eingibst ?
Vergiss nicht, im guten alten DOS gabs mehrere Arten von Speicher:

konventionell => die ersten 640 KB, von denen möglichst viel frei sein sollte
XMS => extended memory
EMS => expanded memory

bei mir zeigt der mem Befehl in der DosBox folgende Werte an:

Bild gelöscht

nobody4ever

Reputation

13.380

  • Thread ErstellerThread Ersteller
  • 8.245 Beiträge
  • registriert vor 13 Jahren

0

Fussballgott

Hallo!
Irgendwie seit ihr alle schlauer als ich und schafft es mit dem mounten.
Ich kann das nicht mal, weil immer wenn ich den Befehl eingeben will springt er bei mir wenn ich "\" eingebe (über die Alt + Nummerntasten) in die nächste zeile...dann gebe ich noch "Dos" ein und jedesmal kommt "unbekannter Befehl".
Kann mir bitte jemand helfen der es mit dem mounten richtig gut drauf hat? Danke im Voraus.

Fussballgott

Reputation

0

  • 1 Beiträge
  • registriert vor 11 Jahren
StartseiteAntworten

1 - 30 von 97

Gehe zur Seite

Seite 1 von 4